using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" +(?=\d+\.)";
string substitution = @"\n";
string input = @"1. Moore, Roger
2. Connery, Sean
3. ....
100. Dalton, Timothy
110. Bronson, Pierce 111. Gomez, Selena 112. Portman, Nathalie
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}