import re
regex = re.compile(r" +(?=\d+\.)", flags=re.MULTILINE)
test_str = ("1. Moore, Roger\n"
"2. Connery, Sean\n"
"3. ....\n"
"100. Dalton, Timothy\n"
"110. Bronson, Pierce 111. Gomez, Selena 112. Portman, Nathalie\n")
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)