$re = '/(\([^\(]*\))/';
$str = '( rafa / %aa)+(23+34)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;