import re
regex = re.compile(r"(\([^\(]*\))")
test_str = "( rafa / %aa)+(23+34)"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)