# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\baccord\b|\G(?<!^))[^)\s]*\K\s+/%20/gm;t' <<< "A scripture reference like [Luke 2:12, 16](accord://read/?Luke 2:12, 16) should be clickable."