using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^09\d{8}$";
string input = @"09123456799";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}