$re = '/^09\d{8}$/';
$str = '09123456799';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);