package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^09\d{8}$`)
var str = `09123456799`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}