package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{2}(\d{2})`)
var str = `1091 foo address
1016 foo 1010 address
foo 1081 address
10 bar address
8 baz address`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}