$re = '/^\d{2}(\d{2})/m';
$str = '1091 foo address
1016 foo 1010 address
foo 1081 address
10 bar address
8 baz address';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);