const regex = /^\d{2}(\d{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{2}(\\d{2})', 'gm')
const str = `1091 foo address
1016 foo 1010 address
foo 1081 address
10 bar address
8 baz address`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}