use strict;
my $str = 'Test string 1.234 0.155.1 5.67799350,-2.654657
.59 _4.567_ abc345.67899abc';
my $regex = qr/[-+]?(?<!\d\.)(?<!\d)\d*\.\d+(?!\.?\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}