$re = '/[-+]?(?<!\d\.)(?<!\d)\d*\.\d+(?!\.?\d)/m';
$str = 'Test string 1.234 0.155.1 5.67799350,-2.654657
.59 _4.567_ abc345.67899abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);