re = /[-+]?(?<!\d\.)(?<!\d)\d*\.\d+(?!\.?\d)/m
str = 'Test string 1.234 0.155.1 5.67799350,-2.654657
.59 _4.567_ abc345.67899abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end