$re = '/(http[s]?:\/\/|www\.)example\.com/m';
$str = 'https://example.com
http://example.com
https://myexample.com
https://www.example.com
http://www.example.com
http://www.myexample.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);