re = /(http[s]?:\/\/|www\.)example\.com/m
str = 'https://example.com
http://example.com
https://myexample.com
https://www.example.com
http://www.example.com
http://www.myexample.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end