// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(http[s]?:\/\/|www\.)example\.com").unwrap();
let string = "https://example.com
http://example.com
https://myexample.com
https://www.example.com
http://www.example.com
http://www.myexample.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}