package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\$SHA\$([a-f0-9]+)\$([a-f0-9]+)$`)
var str = `$SHA$7b11fd7c3568e2cf$2e0380db347bbc210bb10c117dbcb7a7fdba831513eec387666571c7a3ca051e`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}