const regex = /^\$SHA\$([a-f0-9]+)\$([a-f0-9]+)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\$SHA\\$([a-f0-9]+)\\$([a-f0-9]+)$', 'g')
const str = `\$SHA\$7b11fd7c3568e2cf\$2e0380db347bbc210bb10c117dbcb7a7fdba831513eec387666571c7a3ca051e`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}