re = /^\$SHA\$([a-f0-9]+)\$([a-f0-9]+)$/
str = '$SHA$7b11fd7c3568e2cf$2e0380db347bbc210bb10c117dbcb7a7fdba831513eec387666571c7a3ca051e'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end