using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w*(?!\B'\B)'\w*";
string input = @"I've never 'had somebody [redacted-number] [redacted-number] [redacted-number] not. not' you're 123'45 '";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}