#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mxs)(?:\n+|\A)?" & @CRLF & _
"(?<code_all>" & @CRLF & _
" (?<code_start>" & @CRLF & _
" [ ]{0,3}" & @CRLF & _
" \`{3,}" & @CRLF & _
" )" & @CRLF & _
" \n+" & @CRLF & _
" (?<code_content>.*?)" & @CRLF & _
" \n+" & @CRLF & _
" (?<!`)" & @CRLF & _
" \g{code_start}" & @CRLF & _
" (?!`)" & @CRLF & _
" [ \t]*" & @CRLF & _
" \n" & @CRLF & _
")" & @CRLF & _
"(?<code_trailing_new_line>\n|\Z)"
Local $sString = "```" & @CRLF & _
"<p>```" & @CRLF & _
"~~~" & @CRLF & _
"<p>```" & @CRLF & _
"```" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")