using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\n+|\A)?
(?<code_all>
(?<code_start>
[ ]{0,3}
\`{3,}
)
\n+
(?<code_content>.*?)
\n+
(?<!`)
\g{code_start}
(?!`)
[ \t]*
\n
)
(?<code_trailing_new_line>\n|\Z)";
string input = @"```
<p>```
~~~
<p>```
```
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}