const regex = /(?:\n+|\A)?
(?<code_all>
(?<code_start>
[ ]{0,3}
\`{3,}
)
\n+
(?<code_content>.*?)
\n+
(?<!`)
\g{code_start}
(?!`)
[ \t]*
\n
)
(?<code_trailing_new_line>\n|\Z)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\n+|\\A)?
(?<code_all>
(?<code_start>
[ ]{0,3}
\\`{3,}
)
\\n+
(?<code_content>.*?)
\\n+
(?<!`)
\\g{code_start}
(?!`)
[ \\t]*
\\n
)
(?<code_trailing_new_line>\\n|\\Z)', 'gms')
const str = `\`\`\`
<p>\`\`\`
~~~
<p>\`\`\`
\`\`\`
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}