#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?<=Sub Total )\d+[.]\d+)|((?<=GST \d\d% )\d+[.]\d+|(?<=GST \d% )\d+[.]\d+)|((?<=Total )\d+[.]\d+)"
Local $sString = "Sub Total 15100.00" & @CRLF & _
"GST 8% 1208.00" & @CRLF & _
"Total 16308.00" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")