re = /((?<=Sub Total )\d+[.]\d+)|((?<=GST \d\d% )\d+[.]\d+|(?<=GST \d% )\d+[.]\d+)|((?<=Total )\d+[.]\d+)/m
str = 'Sub Total 15100.00
GST 8% 1208.00
Total 16308.00
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end