import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<=Sub Total )\\d+[.]\\d+)|((?<=GST \\d\\d% )\\d+[.]\\d+|(?<=GST \\d% )\\d+[.]\\d+)|((?<=Total )\\d+[.]\\d+)";
final String string = "Sub Total 15100.00\n"
+ "GST 8% 1208.00\n"
+ "Total 16308.00\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}