import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d(?=\\d*\\*?\\d*[ ,;])[\\d*]{0,9}[ ,;])*\\d(?=\\d*\\*?\\d*$)[\\d*]{0,9}$";
final String string = "1234567890,123456*0,6123\n"
+ "012345678,124*6890\n"
+ "1234567890;12345677,\n"
+ "1234567890,1234\n"
+ "123* 12 2**";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}