re = /^(?:\d(?=\d*\*?\d*[ ,;])[\d*]{0,9}[ ,;])*\d(?=\d*\*?\d*$)[\d*]{0,9}$/m
str = '1234567890,123456*0,6123
012345678,124*6890
1234567890;12345677,
1234567890,1234
123* 12 2**'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end