import re
regex = re.compile(r"^(?:\d(?=\d*\*?\d*[ ,;])[\d*]{0,9}[ ,;])*\d(?=\d*\*?\d*$)[\d*]{0,9}$", flags=re.MULTILINE)
test_str = ("1234567890,123456*0,6123\n"
"012345678,124*6890\n"
"1234567890;12345677,\n"
"1234567890,1234\n"
"123* 12 2**")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")