package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<[^>]+>|[<>&]`)
var str = `<p>text</p> <strong>bold</strong> and <em>italic</em> & <>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}