re = /<[^>]+>|[<>&]/m
str = '<p>text</p> <strong>bold</strong> and <em>italic</em> & <>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end