$re = '/[aj]/m';
$str = 'java 11_34-1938 tab
new line';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);