import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "CC :' \\d+' de DN : 'CN=(?<CN>[^,]+)[^']+'\\n(- CODE \\(serial : (?P<CODE>\\d+)\\) error.\\n-+\\n)+";
final String string = "CC :' 223' de DN : 'CN=XXX 2025, ABCDEFGHIJKLMNOPQRSTUVWXYZ'\n"
+ "- CODE (serial : 1234) error.\n"
+ "---------------------------------------------------------\n"
+ "- CODE (serial : 5678) error.\n"
+ "---------------------------------------------------------\n"
+ "- CODE (serial : 5678) error.\n"
+ "---------------------------------------------------------\n"
+ "- CODE (serial : 5678) error.\n"
+ "---------------------------------------------------------\n"
+ "- CODE (serial : 5678) error.\n"
+ "---------------------------------------------------------\n"
+ "CC :' 224' de DN : 'CN=YYY 2025, ABCDEFGHIJKLMNOPQRSTUVWXYZ'\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}