import re
regex = re.compile(r"CC :' \d+' de DN : 'CN=(?<CN>[^,]+)[^']+'\n(- CODE \(serial : (?P<CODE>\d+)\) error.\n-+\n)+")
test_str = ("CC :' 223' de DN : 'CN=XXX 2025, ABCDEFGHIJKLMNOPQRSTUVWXYZ'\n"
"- CODE (serial : 1234) error.\n"
"---------------------------------------------------------\n"
"- CODE (serial : 5678) error.\n"
"---------------------------------------------------------\n"
"- CODE (serial : 5678) error.\n"
"---------------------------------------------------------\n"
"- CODE (serial : 5678) error.\n"
"---------------------------------------------------------\n"
"- CODE (serial : 5678) error.\n"
"---------------------------------------------------------\n"
"CC :' 224' de DN : 'CN=YYY 2025, ABCDEFGHIJKLMNOPQRSTUVWXYZ'\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")