# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\S+\s\w).*/$1/gm;t' <<< "John James Doe"