package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\S+\s\w).*`)
var str = `John James Doe`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}