use strict;
my $str = 'John James Doe';
my $regex = qr/^(\S+\s\w).*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";