using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+)=[\'""]?((?:(?!\/>|>|""|\'|\s).)+)";
string input = @"<a href=test.html target=xyz>
<a href=test.html target=xyz/>
<a href=test.html target=xyz />
<a href=""test.html"" target=""xyz"">
<a href='test.html' target=""xyz"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}