$re = '/(\S+)=[\'"]?((?:(?!\/>|>|"|\'|\s).)+)/';
$str = '<a href=test.html target=xyz>
<a href=test.html target=xyz/>
<a href=test.html target=xyz />
<a href="test.html" target="xyz">
<a href=\'test.html\' target="xyz">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);