re = /(\S+)=[\'"]?((?:(?!\/>|>|"|\'|\s).)+)/
str = '<a href=test.html target=xyz>
<a href=test.html target=xyz/>
<a href=test.html target=xyz />
<a href="test.html" target="xyz">
<a href=\'test.html\' target="xyz">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end