import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[ \\t]+\\$[ ]*(?P<in_line>[^$\\n]+?)[ \\t]*\\$[ \\t]+";
final String string = "Lorem ipsum dolor sit ame $ a = \\{ b, c \\} $ Lorem 100 \\$ ipsum\n"
+ "$$ \\left \\{ \n"
+ " \\begin{array}{cl}y_1 =&3 x_1 - x_2 + x_3\\\\y_2 =&2 x_2\\\\y_3 =&x_1 - x_2 + 3 x_3\\end{array} \n"
+ " \\right.\n"
+ " \\Leftrightarrow \\left \\{ \n"
+ " \\begin{array}{cl}8 x_1 =&3 y_1 + y_2 -y_3\\\\8 x_2 =&4 y_2\\\\8 x_3 =&-y_1 + y_2 + 3 y_3\\end{array} \n"
+ " \\right.\n"
+ " $$ \n"
+ "Lorem ipsum dolor\n"
+ " $$ \\left \\{ \n"
+ " \\begin{array}{cl}y_1 =&3 x_1 - x_2 + x_3\\\\y_2 =&2 x_2\\\\y_3 =&x_1 - x_2 + 3 x_3\\end{array} \n"
+ " \\right.\n"
+ " \\Leftrightarrow \\left \\{ \n"
+ " \\begin{array}{cl}8 x_1 =&3 y_1 + y_2 -y_3\\\\8 x_2 =&4 y_2\\\\8 x_3 =&-y_1 + y_2 + 3 y_3\\end{array} \n"
+ " \\right.\n"
+ " $$ \n"
+ "Lorem ipsum dolor $$$ Lorem ipsum dolor $$$. foo sit ame $ a = \\{ b, c \\} $ \n\n"
+ "Il s'installe en ligne de commande avec le gestionnaire de paquets `opam`:\n\n"
+ " $ opam update \n"
+ " $ opam install hevea\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}