package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^[a-f0-9\-]{36}$`)
var str = `4a62de4f-1a12-43bf-90a5-32825cc4522f`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}