const regex = /^[a-f0-9\-]{36}$/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-f0-9\\-]{36}$', 'gi')
const str = `4a62de4f-1a12-43bf-90a5-32825cc4522f`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}