$re = '/^[a-f0-9\-]{36}$/i';
$str = '4a62de4f-1a12-43bf-90a5-32825cc4522f';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);