# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:[a-z]\))?([\s\S]+?)(?:<br\s*\/>\s*)?(?=[a-z]{1}\)|$)"
test_str = ("<strong>Preencha</strong> a lacuna e assinale a alternativa correta.<br />\n"
"<br />\n"
"I - capacitação técnico-profissional: Comprovação do licitante de possuir em seu quadro permanente, na data prevista para entrega da proposta, ________________, detentor de atestado de responsabilidade técnica por execução de obra ou serviço de características semelhantes, limitadas estas exclusivamente às parcelas de maior relevância e valor significativo do objeto da licitação, vedadas as exigências de quantidades mínimas ou prazos máximos (Lei 8.666/1993 Art N° 30).<br />\n"
"<br />\n"
"a)<strong>profissional</strong> de nível superior<br />\n"
"b)profissional de nível superior ou outro devidamente reconhecido pela entidade competente<br />\n"
"c)profissional capacitado<br />\n"
"d)profissional de nível minimamente técnico<br />\n"
"e)profissional especializado no objeto da <strong>licitação</strong><br />")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.