import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*[+*-]{2})\\S+";
final String string = "-t2ext++text\n"
+ "+text+-text\n"
+ "t*ext+*text\n"
+ "t5e-xt--text\n"
+ "te-xt-+text\n"
+ "t5ex-t-*tex-t\n"
+ "te5xt**text\n"
+ "t8ext*-te9xt\n"
+ "te77*xt*+te*xt\n"
+ "t8ext-te9xt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}