use strict;
my $str = '-t2ext++text
+text+-text
t*ext+*text
t5e-xt--text
te-xt-+text
t5ex-t-*tex-t
te5xt**text
t8ext*-te9xt
te77*xt*+te*xt
t8ext-te9xt';
my $regex = qr/^(?!.*[+*-]{2})\S+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}