$re = '/^(?!.*[+*-]{2})\S+/m';
$str = '-t2ext++text
+text+-text
t*ext+*text
t5e-xt--text
te-xt-+text
t5ex-t-*tex-t
te5xt**text
t8ext*-te9xt
te77*xt*+te*xt
t8ext-te9xt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);