using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^;]+);(?:\s*([^=]+)=((?<q>\""?)[^""]*\k<q>);?)*$";
string input = @"attachment; filename=""fname.ext""; param1=""A""; param2=""A""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}